Copyright (c) 2012-2016 Hyperion Entertainment and contributors.

Bars & Pipes Professional: Multi-Track Editing

From AmigaOS Documentation Wiki
Jump to: navigation, search

Introduction

Although Bars&Pipes Professional includes sophisticated Graphic and List Editors, you can also perform many editing functions from the Tracks window. In particular, you can Cut, Copy, and Paste individual Tracks, or perform these functions globally on all Tracks. These operations involve the Edit Flags, Edit menu, and ClipBoard.

In addition to the Tracks window, you can also perform multi-track edits from the Song Construction and Media Madness windows. For our examples, however, we will concentrate on the Tracks window.

Clip Editing

All Edit menu operations use "Clips", which store and retrieve edited information. A Clip stores a section of music containing one or more Tracks. A Clip Buffer is a place in your computer's memory that stores a Clip.

The Track Clip Buffers

Each Track has its own Clip Buffer that stores a single Clip. The Cut and Copy commands replace the previous contents of the Track's Clip Buffer with the new Clip; the Paste and Mix commands copy the contents of the Clip Buffer to the Track.

The ClipBoard

Unlike an individual Tracks Clip Buffer, the ClipBoard allows you to work with multiple Cliresents you with filtering options. The Cut and Copy commands add a new Clip to the ClipBoard; the Paste and Mix commands copy the selected Clip to the Tracks. To use the ClipBoard instead of the Clip Buffer, open the ClipBoard by selecting the Windows menu or double-clicking on the Clip Board icon. While the ClipBoard is open, Clips are sent to it instead of the Track's Clip Buffers.

The Edit Window Clip Buffers

Although you don't use the Graphic and List Editor windows when editing multiple Tracks, it's important to understand their usage of Clip buffers:

Like a Track, each Edit window maintains its own Clip Buffer. All Cut and Paste commands in the Editor's Edit menu use this Clip Buffer when the ClipBoard window is not open. When the ClipBoard window is open, the Edit window uses the ClipBoard, just as the multi-track editing operations do. This means that you can Cut and Paste between the Edit windows and individual Tracks in the Tracks, Media Madness, and Song Construction windows.

The Edit Flags

Use the Edit Flags to mark a section of music for editing. The Flags look like purple slanted triangles, and sit directly above the Track displays in the Tracks, Media Madness, and Song Construction windows.


Position these Flags to indicate where you want your edits to occur. The left Edit Flag, designated by a triangular flag with the mast on the right, identifies where an edit operation starts, while the right Edit Flag, designated by a triangular flag with the mast on the left, identifies where an edit operation ends.

Positioning The Edit Flags

To position a Flag, drag it with the mouse. If the desired position is not visible in the display, first scroll the display so that the desired position is visible, then drag the Flag into position.

Dragging a Flag all the way to the left tells Bars&Pipes Professional to place it at the very beginning of your Song or Track. Dragging it all the way to the right indicates that you want it placed at the end of the Song or Track.

Tip
Notice that as you drag the Flag its position is shown in the LED displays in the Transport Controls Mini Transport and Tracks windows.

You can also position the Flags by entering exact values with the Set Flags Window. To enter exact values open the Set Flags Window from the Windows menu.


Enter the values in Measures, Beats, and Clocks, or, if the SMPTE/Music Time button is set to SMPTE, set the time in Hours, Minutes, Seconds, and Frames. Once you have entered a number, remember to press the Return key, which enters the new value and moves the Flag to its new position.

Flag Alignment

You can specify whether the Flag automatically aligns with Measures, Beats, Seconds, Frames, or Anywhere, by selecting the desired option from the Align with... command in the Preferences menu. If you select Align with Measures, the Edit Flag always sticks to the measure boundary just to the left of, or under, the place where you drag it. If you select Align with Beats, it sticks to the beat boundary. Seconds stick to seconds boundaries, Frames stick to SMPTE frame boundaries, and if you select Align with Anywhere, it stays exactly where you place it.

Alternatively, you can set the Alignment with the four Alignment buttons located in the Set Flags window. "->M<-" sets the alignment to Measures, "->B<-" sets the alignment to Beats, "->S<-" sets the alignment to Seconds, and "->F<-" sets the alignment to Frames. If no button is selected, the alignment is set to Anywhere.

Note
If you align the Edit Flags on measure boundaries, the Time Signature and Key & Scale/Mode Parameters will be incorporated in the edit. Otherwise, they will not.

Selecting Tracks to Edit

You can edit one Track, a Group of Tracks, or the entire Track list at once.

Editing One Track Only

To edit one Track only, select the Track, activate the Solo mode and choose the appropriate edit command. This is the only option available in the Graphic and List Editors.

Editing A Group Of Tracks

To edit an entire Group of Tracks, select that group with the Group Number button or make a temporary Group by shift-clicking several Tracks. Then solo the Group with the Solo button and choose the appropriate Edit command.

Editing All Tracks

To edit all Tracks, make sure the Normal/Solo/Mute button is in Normal mode, then mark off the desired area and use the appropriate edit command.

The Edit Operations

The Edit menu operations work in conjunction with the Edit Flags and the Normal/Solo/Mute button.

Once you have aligned the Edit Flags and set the Normal/Solo/Mute button, select the desired operation from the Edit menu. Once they've been executed, all of the Edit menu commands automatically turn off the Solo button (if selected), so that you can quickly listen to your changes.

The following shows the menu command followed by the hotkey in parenthesis.

Cut (Right Amiga - X)
The Cut command cuts a section from your Song or selected Track. Cut removes the section between the Edit Flags and shifts everything to the right of the section to the left Edit Flag. This is analogous to cutting out a section of tape physically and splicing the remaining ends together.
Use the Paste command to insert the Clip elsewhere in your Track, or the Mix command to merge the Clip with existing notes. Notice that the Solo button is automatically turned off, after the cut is made. If you plan to Paste into just one Track, you must reactivate the Solo button.
Copy (Right Amiga - C)
The Copy command copies a section, without actually removing it, for use with the Paste or Mix commands. Nothing visibly happens, but the section between the Edit Flags is now available for Pasting.
Paste (Right Amiga - P)
The Paste command inserts a cut or copied section into the Song or Track. It's not necessary to set the right Edit Flag, since the length of the inserted section is determined at the time it is cut or copied. For example, if you cut a four-measure section, the Paste command inserts those same four measures and moves everything to the right of the insertion by four measures.
You can do multiple Paste operations with the same Clip it does not change until you cut or coy another section of the Track.
Note
Remember to activate the Solo button before you Paste, if you intend to Paste into just one Track or Group.
Mix
The Mix commands merge a copied or cut section with the existing Song or Track. As with Paste, you need only set the Left Edit flag, unless you explicity wish to limit the pasted size with the Mix To Right Edit flag command. Unlike the Paste command, Mix does not increase the legth of the Track; rather it adds the notes to the notes already in the section.
Erase (Right Amiga - E)
The Erase command clears the section between the left and right Edit Flags. Erase removes all events and your Sequence is silent during this section. This is analogous to erasing a section of tape.
Insert (Right Amiga - I)
The Insert command inserts a blank space in your music. This command is useful when you want to add a section to your Song somewhere in the middle of it. Insert the section, then use whatever methods you prefer to fill the gap with music.
In other words, the section contained between the Edit Flags shifts to the right of the right Edit Flag, and the section between the edit flags is becomes empty.
Delete
To delete a section between the right and left Edit flags, use the Delete command. This command operates identically to the Cut command, but does not place the deleted section into the Clip buffer or ClipBoard.
Note
You can still use the Undo command.
Toolize (Right Amiga - T)
The Toolize command uses the currently selected Tool in the ToolPad to process the section marked off by the Edit Flags. This command is ghosted if there is no Tool in the ToolPad
Repeat (Right Amiga - R)
The Repeat command repeats a section of your Song one or more times. Repeat makes multiple copies of the section designated by the Edit Flags and inserts them in the Song.


When you select the Repeat command, a requester opens and asks you to specify the number of times to repeat.
Note
This is NOT the number of times that the section plays, but the number of times it repeats. Hence, selecting "1" repeats the section one time.
The repeated section appears immediately following the source section. Enter a number and select Okay to repeat, or Cancel, to abort.
Propagate (Right Amiga - A)
The Propagate command is the only Edit command used in association with the A-B-A feature of the Song Construction window. (Please see Song Construction.)
If you make a change to an A-B-A section and you'd like the change to be reflected in all other copies of that specific section, use the Propagate command in conjunction with the left Edit Flag.
To do so, place the left Edit Flag on or within the boundaries of the section to be propagated. Bars&Pipes Professional then rewrites all occurrences of that section to include the change.
For example, if you change some notes in the first instance of your "A" section, place the left Edit Flag within or on that section's boundaries and the Propagate command changes all other instances of your "A" section.
The Propagate command always uses the first instance of each section to make its changes; therefore, in order to use Propagate successfully, you must always edit the first section.
Undo (Right Amiga - U)
The Undo command returns your Song to its state prior to the last operation. In addition to undoing all of the commands in the Edit menu, it undoes other actions, including the last time you recorded.

Merging Groups Of Tracks Together

You can merge several Tracks into one Track in a single operation. This is useful for merging several Tracks of drums into a single drum track, or merging several Tracks recorded from different MIDI channels from a guitar controller into a single Track for tablature printing.

Tip
In the latter case, where each guitar string is recorded on a separate Track, open the Graphic Editor for each track separately, and tabulate on the correct string for each track. Then, merge the Tracks together. The notes retain their original string assignments for accurate tablature transcriptions.

Example: Merging Several Tracks

  1. Open the main Tracks window. Choose a blank, unused track to merge the tracks into. If you do not have a blank track, select New from the Track menu to create a new blank track.
  2. Activate one of the Group button numbers (1-8) in the upper left corner of the Tracks window. This places Bars&Pipes in Group mode. If any tracks turn white, they are already members of this group, and you should choose a different number.
  3. Activate the Group button (the button that says "Group" on it). This places you in Group Edit mode. Any Track you click on becomes a member of this new group.
  4. Click on the tracks to merge together. Each track turns white to indicate it is a member of the group.
  5. Deactivate the Group button, but leave the Group Number button active. This takes you out of Group edit mode and back into Group mode.
  6. Choose the Group/Merge... menu command. "Select the Merge Track:" appears in the Track window's title bar.
  7. Click on an empty Track. The Track fills with the merged contents of the group of tracks. The original group is left intact.
  8. If desired, choose the Group/Remove menu command to remove all the original tracks from the song. Alternatively, you may wish to click on the solo/mute button until the group of tracks is muted, in case you ever wish to reuse the original group of tracks.
  9. Deactivate the Group Number button to return to normal track editing mode.
Tip
Optionally, use multiple selection to create a temporary group. To do so, hold down on the Shift key and click one by one on the Tracks that you would like to merge.

Splitting A Drum Track Into Several Parts

There are times when you might wish to split a single track of multiple drum sounds into several tracks of single drum sounds. For instance, this might be useful if you wish to set an echo on the snare drum, but not the bass drum.

The Track/Split menu command provides the ability to split a Track into component parts in a single move.

Tip
You can also accomplish similar and sometimes more intriguing results using different Tools from the variety of Tool Kits available.

Example: Splitting a drum track into component drum parts

  1. Open the main Tracks window.
  2. Click on the track that you wish to split.
  3. Choose the Track/Split menu command. A requester will appear that tells you how many Tracks will be created if you choose to continue.
  4. Choose Yes to split the track. The track splits into several Tracks, all having the same name and MIDI channel as the original track.
Note
You can reconstruct the original track by merging all split tracks back together. See above.

Clean Cuts

The Clean Cuts option in the Preferences menu controls how Bars&Pipes Professional treats notes that extend over Clip boundaries.

Without Clean Cuts, when Bars&Pipes Professional creates a Clip, it extracts all notes up to the right Edit Flag and leaves the note durations untouched. If a note near the end of the Clip has a duration that hangs over beyond the right edit Flag, it overlaps when pasted in elsewhere.

With Clean Cuts enabled, Bars&Pipes Professional chops notes that overlap the start and end of the Clip into two notes apiece. And, when pasting, if two identical notes butt up to each other on the Clip boundary, it merges them into one.

Note
The Clean Cuts option also controls how notes cut and merge when Punching in and Out during recording.

The ClipBoard

The ClipBoard provides a convenient way to move music Clips from one Track or Group of Tracks to another. It also allows you to filter out events and Song parameters while you cut and paste. And, it provides a convenient storage spot to post Clips that you'd like to use later. You can even load and save Clips to disk.

Accessing The Clipboard

Use the ClipBoard with the Track, Song Construction, Media Madness, and any Edit window. To open the ClipBoard, double-click on its icon along the right side of the screen (the icon that looks like a Clipboard), or select ClipBoard from the Windows menu.


The ClipBoard window controls the use of the ClipBoard. Whenever the window is open, Clips are automatically sent to it, rather than the associated Clip Buffer. As long as the ClipBoard window remains open, all Clip edit operations in all windows pass their Clips through the ClipBoard.

The ClipBoard window displays the list of Clips, with the currently selected Clip highlighted. Each Clip in the list displays its name, the number of Tracks in the Clip, and the length of the Clip in Song-time.

Note
If the number of Tracks is denoted as a capital S, this means that the Clip is for a single Track only.

The ClipBoard Commands

To select a Clip, click on its name in the list. The Clip highlights and its name displays after the Clip Name: prompt. Use the scroll bar and arrows to scroll the Clip list up or down.

The following features are found in the ClipBoard window:

Clip Name
To change the name of the selected Clip, enter the new name after the Clip Name: prompt.
Note
By default, Bars&Pipes Professional assigns names in the form "Clip #<number>".
Clear
To remove a Clip, select the Clip, and then select the Clear button.
Load Clip
To load a previously saved Clip, use the Load Clip command from the File menu.
Save Clip
To save the selected Clip to disk, use the Save Clip command from the File menu. Once the file requester opens, select or enter a file name and click on Save.
Clear all Clips
To delete the entire list of Clips, select the Clear All Clips command from the File menu.

Editing with the ClipBoard

When you enable the ClipBoard, the four Edit menu commands, Cut, Copy, Paste, and Mix pass Clips to and from the ClipBoard. To Cut, Copy, Paste, or Mix an individual Track or Group of Tracks instead of all Tracks, click on the Solo button before selecting the specific edit command.

Note
When you Cut or Copy all Tracks into the ClipBoard, it displays a Clip size one greater than the number of Tracks. This happens because it also includes the hidden Master Parameters Track.

Edit Menu Commands And The Clipboard

Here is how each edit command behaves in conjunction with the ClipBoard:

Cut (Right Amiga - X)
The Cut command removes the section between the Edit Flags and places it in the ClipBoard. Notice that the new Clip is highlighted.
Copy (Right Amiga - C)
The Copy command duplicates the section between the Edit Flags and places it, highlighted, in the ClipBoard. The source Track(s) remains unchanged.
Paste (Right Amiga- P)
The Paste command inserts the selected (highlighted) Clip at the point marked by the left Edit Flag. The Clip remains in the ClipBoard, so that you can make multiple pastes.
You can control which Parameters and Event types you paste with the Include menu. (See below.) You can also control which Tracks receive pasted Clips. (See below.)
Mix
The Mix commands merge the selected Clip into the target Track(s). This command excludes Parameters from the mix. You can, however, choose which MIDI Events to mix with the Include menu.
There are times when you may cut or copy a clip from one Track and wish to mix (e.g. Merge) its contents into another Track.
Note
When you past a clip into a Track, it actually inserts the clip into the Track, moving the contents of the Track to the right to make room for the clip. If you mix the clip into the Track instead, it does not move the Track's original contents to the right.

Example: Mixing the contents of measures 5-8 of one track into measures 10-13 of another:

  1. Open the Main Track window.
  2. Click on the Track to copy the clip from. The Track highlights in white.
  3. Set the Left Edit flag at the beginning of measure 5.
  4. Set the Right Edit flag at the beginning of measure 9.
  5. Click on the Solo button in the upper left hand corner of the Tracks window. All Tracks except the highlighted one become muted.
  6. Choose the Edit/Copy menu command. If it is not already open, the Clipboard window opens and displays the new clip. It highlight the new clip in red, and it displays the name after the Clip Name: prompt. The name in the list appears with an "S", signifying a single Track, and "0003.00.00", signifying a length of 3 measures, no beats, and no clocks.
  7. Click on the destination Track. It highlights in white.
  8. Once again, click on the solo button to solo the Track.
  9. Move the Left Efit flag to the beginning of measure 10. It does not matter where the Right Edit flag is.
  10. Choose the Edit/Mix To End Of Clip menu command. The entire contents of the clip are mixed into the track.
Note
This causes the next Edit operation to work only on the soloed Track.

The menu option Edit/Mix To Right Edit Flag work similarly to the Mix To End Of Clip command, except that it stops mixing the clip when it reaches the Right Edit flag.

For instance, if the Right Edit flag had been set at the beginning of measure 11 in the above example, only the first measure of the clip would have been mixed into the Track.

Cutting From One Track And Pasting Into Another

If you want to Cut and Paste from one Track to another, you must use the Solo button before each command. When the Solo button is used in conjunction with an editing command, the ClipBoard automatically opens if it is not already open.

To Cut from one Track and paste into another:

  1. Highlight the Track you want to Cut (or Copy) from.
  2. Set the Edit flags around the area you want to Cut (or Copy).
  3. Click on the Solo button.
  4. Select the Cut (or Copy) command from the Edit menu.
  5. Highlight the Track you want to Paste (or Mix) into.
  6. Set the left Edit flag to the position you would like to Paste (or Mix).
  7. Click on the Solo button.
  8. Make certain that the correct Clip is highlighted in the ClipBoard.
  9. Select the Paste (or Mix) command from the Edit menu.
Tip
Another easy way to Cut and Paste from one Track to another is to use the Song Construction window. Please refer to that chapter for more information.

Filtering Clips With The Clipboard

The Include menu is available only when you have selected the ClipBoard window. This menu allows you to select specific Song Parameters and MIDI Events which will be included in the pasting or mixing.

By default, the Include menu includes everything but System Exclusive events. Omit those you don't want by clicking on the particular items in the menu.

Note
During a Mix operation, only MIDI Events are included, and not Parameters.

Multi-Track Clip Alignment

Clips can contain portions of several Tracks. Depending upon whether you're working with one Song or several, you may want to paste multiple Tracks differently. The Align Clips... selection in the Preferences menu gives you two ways to paste multi-track Clips.

When you select By Name, Bars&Pipes Professional pastes multi-track Clips into Tracks with the same names as the Tracks from which the Clips were cut or copied. This method is very useful for moving Clips between Songs, since you do not need to enforce a particular Track order for all of your Songs. Bars&Pipes Professional pastes only the Tracks that have matching names in the Song; other Tracks are not pasted, but do remain in the Clip.

When you select By Position, Bars&Pipes Professional pastes multi-track Clips into the selected Track, and Tracks below, until all Tracks are pasted. This method is useful for moving Clips between Tracks in the same Song, or between Songs without regard to Track names. Pasting "wraps around" from bottom to top, if necessary. For example, if you paste starting three Tracks from the bottom and five Tracks are in the Clip, Bars&Pipes Professional pastes the last two Clip Tracks in the top two Tracks of the Song.