Copyright (c) 2012-2016 Hyperion Entertainment and contributors.

AmigaOS Manual: AmigaGuide

From AmigaOS Documentation Wiki
Jump to: navigation, search

The Amiga Workbench supports a hypertext on-line help function that uses AmigaGuide files. These files are widely used in third-party applications; however, the Release 3 Workbench does not provide any AmigaGuide help about itself other than a help file for AmigaGuide. This appendix describes the following:

  • Accessing AmigaGuide files
  • Using AmigaGuide
  • AmigaGuide menus

Accessing AmigaGuide

When you are running a program or application that uses AmigaGuide, there are three ways to access the AmigaGuide files:

  1. Pressing the Help button while the mouse pointer is over an item on the screen for which you need help.
  2. Selecting the Help menu item.
  3. Opening a .guide file in MultiView.

Figure C-1 illustrates an AmigaGuide Help file found in LOCALE:Help opened in MultiView.

Example AmigaGuide Help Screen

Using AmigaGuide

Use the buttons across the top of the AmigaGuide Help screen to move through the file.

Contents Displays the contents of the AmigaGuide file. Click on a topic to display information about it.
Index Display application-supplied index.
Help Display either the system help or help supplied by an application.
Retrace Pages backwards through opened screens. If you select Contents, selecting Retrace returns you to the last screen you had open.
Browse < Pages backwards through text.
Browse > Pages forward through text.

The AmigaGuide Help text contains terms that are highlighted as buttons. Clicking on these terms displays screens containing further Help information about them. Selecting Retrace after clicking on a highlighted term returns you to the screen from which it came.

AmigaGuide Menus

The AmigaGuide file contains the following menus:

Project Menu

The Project menu contains the following items:

Open Opens a file requester.
Save As Saves the current screen as text.
Print Prints the current screen as text.
About Shows the AmigaGuide release information and contents type of the current file.
Quit Quits the AmigaGuide file.

Edit Menu

The Edit menu contains the following items:

Mark Not available.
Copy Copies current screen to the Clipboard as text.
Select All Not available.
Clear Selected Clears the selection of the block without copying or printing.

Window Menu

The Window menu contains the following items:

Use Separate Screen Opens the AmigaGuide file on its own screen.
Minimize Makes the window as small as it can be.
Normal Sizes the window to the picture or contents size.
Maximize Makes the window the same size as the screen.

Prefs Menu

The Prefs menu contains the following item:

Save As Defaults Saves the size and position of the window for future use.