Copyright (c) 2012-2016 Hyperion Entertainment and contributors.

AmigaOne X1000

From AmigaOS Documentation Wiki
Revision as of 19:58, 2 October 2015 by Steven Solie (Talk | contribs)

(diff) ← Older revision | Latest revision (diff) | Newer revision → (diff)
Jump to: navigation, search

The AmigaOne X1000 is a powerful PowerPC-based high-end computer now available for AmigaOS.

Key Specifications

  • ATX form factor
  • Dual core PWRficient PA6T-1682M 1.8 Ghz PowerISA v2.04+ CPU
  • Xena Co-processor running at 500 Mhz with a XCore XS1-L2 124 SDS
  • ATI Radeon HD 1GB 4650 Graphics Card
  • 7.1 channel HD Audio
  • Memory 4xDDR2 SDRAM Slots
  • 10 USB 2.0
  • 1x Gigabit Ethernet
  • A range of PCIe and PCI slots
  • A Xorro and Compact Flash slot
  • 2x RS-232 serial ports
  • 4x SATA2 connectors
  • 1x PATA connector
  • 1x JTAG connector

Manufacturer

A-Eon Technology is the manufacturer of the AmigaOne X1000 motherboard.

AmigaKit is the worldwide distributor of the AmigaOne X1000 System.

Troubleshooting Tips

X1000 CFE Documentation

Please remember to refer to CFE's documentation located in SYS:Documentation/X1000_CFE.pdf for information on boot configuration.

Where does Kickstart load from?

As soon as the "amigaboot.of" loader begins, it scans all the available AmigaOS partitions it can find. Specifically, the SATA CD-ROM and SATA drive connected to Port1, SATA2 and IDE devices are scanned for partitions which are set as AmigaOS bootable, using the FFS2 or SFS file systems and containing an AmigaOS system. Kickstart from the partition with the highest priority is then loaded. After Kickstart is loaded, ALL drives will be scanned again and Workbench from the highest priority bootable drive will load. If your highest priority bootable drive is not connected to Port1, SATA2 then a kickstart from another drive will be loaded.

So, if you add another drive with bootable partitions, you may need to swap SATA cables to get the kickstart to load from the right place.

X1000 Won't Reboot Reliably

  1. Turn off power to PSU.
  2. Remove plug from PSU.
  3. Remove power connector from the motherboard.
  4. Take out one RAM card leaving only one to the right of the PA6T CPU (i.e. 3rd slot from the left).
  5. While the RAM card is out check the slots 2 & 3 for dust build up (the CPU fan blows dust onto them) and use a small clean brush to remove it.
  6. Plug power connector back on to the motherboard.
  7. Connect PSU power & switch on PSU.
  8. Turn on X1000.

If the X1000 boots up to Workbench, press and hold the power button for 3-5 seconds & it should shut off.

X1000 locks up randomly and doesn't boot reliably

I had this problem for a few months and finally tracked it down to loose SATA power connectors.

I had a PSU Modding kit and made a new power lead, MOLEX to 4 SATA, all on the same lead, spaced to fit 4 drives perfectly with no bent wires.

The new connectors are a much tighter fit and since I changed the lead I've not had a single random lockup and reliable booting.

If you get the insufficient memory error in CFE this is a sign the DVD cable is loose.

X1000 CPU temperatures are rising

  1. Clean both fan filters on the front fan openings.
  2. Clean the fan filter UNDER the power supply unit.

X1000 fails to boot, "Loading" indicator goes full red and then stops

  1. This will happen when booting an older workbench with a newer graphics card.
  2. You'll need to update your PCIGraphics.card and RadeonHD.chip, or revert to an HD4000 series graphics card.

X1000 fails to boot

May also happen if non-bootable media is left in the CD/DVD drive.

X1000 fails to boot, "Failed to load amigaboot.of: Insufficient memory"

  1. Relax your memory isn't fried.
  2. Check the SATA cable to your DVDRW drive (top left on the motherboard)
  3. Don't forget to check the power cable too.

For some reason CFE reports insufficient memory errors when it can't find an optical drive.

If checking cables doesn't correct the problem, check that CFE is able to read the amigaboot.of bootloader. Generally it can read it from an installation CD, a hard disk partition, or even from an internal CompactFlash, but there are constraints which you should be aware of:

  • CFE can only boot on sata drives connected to Sata0 or Sata2 connectors, so check that your DVD drive and your system hardisk are connected to these.
  • CFE can only read a few file systems among which
    • ISO for CDs
    • FFS2, ext2 or FAT for hard disks or CompactFlash
  • CFE can't detect file systems, they must be specified in the boot command
    • for a CD: -fs=isofs
    • for an AmigaOS FFS partition: -fs=amigafs
  • CFE must find an amigaboot.of file on the unit indicated by the boot command, it's up to you to check that it's available

Checking the boot command

The boot menu is configured through a set of MENU_x_LABEL/MENU_x_COMMAND pairs. If one of the entry doesn't work, you have to check that:

  • the unit exists,
  • the file system is correct,
  • the amigaboot.of file is present.

checking the units

At CFE prompt, display your menu commands with the printenv command, you may get such menu entries:

MENU_0_COMMAND=setenv amigaboot_quiet Y ;boot -fs=amigafs ide0.0:amigaboot.of 
MENU_1_COMMAND=setenv amigaboot_quiet Y ;boot -fs=iso atapi0.1:amigaboot.of

To check what CFE may access, type the show device command. (NB: hard disks are displayed as ide units and CD/DVD drives as atapi units) For example:

CFE> show devices
Device Name          Description
-------------------  ---------------------------------------------------------
uart0                NS16550 UART at 0xFCFF03F8
pcconsole0           PC Console (USB/VESA)
eeprom0              Microchip 24LC128 EEPROM on SMBus channel 0 dev 0x57
eth0                 PA Semi Ethernet (ge3) at 0xE00A3000 (02-00-E0-0A-30-00)
flash0.os            SPI flash at FFE00000 offset 00000000 size 1024KB
flash0.boot          SPI flash at FFE00000 offset 00100000 size 1024KB
therm0               TI TMP423 Thermal Sensor on SMBus channel 0 dev 0x4C
cf0                  CompactFlash ATA disk unit 0 at 0xF0000000
atapi0.0             PCI IDE disk unit 0 at I/O 0000 (PCI:E0590000)
ide0.1               PCI IDE disk unit 1 at I/O 0000 (PCI:E0590000)
eth1                 RTL8139 Ethernet at 0xA0310000 (00-50-fc-1f-1f-de)
usbdisk0             USB Disk unit 0
usbdisk1             USB Disk unit 1
*** command status = 0
CFE> 

In this example you should notice that CFE does not see ide0.0 and atapi0.1 but ide0.1 and atapi0.0. In this case, it means the menu commands are based ont the hard disk being connected on Sata0 and the CD drive on Sata2, but in fact it's connected the other way around. Either you modify the menu commands, or you swap the cables on the Sata connectors 0 and 2.

checking file system

Once your units are correctly identified, you should check the file system is correct with the dir command. Note that the error message may be different depending on the type of unit and the file system. Just keep in mind that if the command status is 0, the file system is correct.

  • trying to read an SFS/02 partition:
CFE> dir -fs=amigafs ide0.1,prod:
Could not init file system: Unsupported function
*** command status = -19
  • trying to read a wrong unit:
CFE> dir -fs=amigafs ide0.0:
Could not init file system: Insufficient memory
*** command status = -5
  • trying to read a FAT partition as FFS:
CFE> dir -fs=amigafs cf0:
Could not init file system: File not found
*** command status = -18
  • trying to read an FFS partition as FAT:
CFE> dir -fs=fat ide0.1:
Could not init file system: File system not recognized
*** command status = -29
  • and finally finding the Grail:
CFE> dir -fs=amigafs ide0.1:
Directory
   amigaboot.of                        51420      ------------r---

51420 bytes in 1 files
0 directories
*** command status = 0

finding amigaboot.of

Once you get the dir command working, make sure it lists the amigaboot.of file like in the example above, as CFE will load it and pass control to it to continue the boot process, either to present a second boot menu based on kicklayouts or to directly load the kickstart.


X1000 won't boot (black screen, no boot at all) with only 3 LEDs lighting on motherboard

Check the CMOS battery.

X1000 boots to black screen with RadeonHD 2.7 driver

Several users have reported the XFX Radeon R9 270X card is not compatible with the RadeonHD 2.7 driver. Another user reported the MSI Radeon R9 270X card is also not compatible. It is probably best to avoid the "270X" cards entirely.

X1000 Keyboard does not work while booting

Plug the keyboard into the USB connector closest to the white audio jack.

This is "upper left" as you look at the back of the case. (ref Sys:documentation/X1000_QuickstartGuide.pdf page 9)

Do not plug a keyboard with a built in hub in that socket, CFE does not approve.

Creating a new boot CD step by step

This is taken from a post on Amigaworld.net by Lyle Hazelwood.

If you have upgraded to a newer graphics card, any old boot CDs that don't have the new RadeonHD drivers will not boot. Here is a simple way to create a more useful CD.

You'll need to go back to a compatible graphics card to get running long enough to do this. I hope your original video card is still available to you.

Requirements

You have a Bootable Recovery CD, like "AmigaOS 4.1 Update 5". Your current Workbench has been upgraded with the new RadeonHD drivers. You have a blank CDROM disk and a drive capable of burning it.

Step by step

1. Check SYS:Utilities for "AmiDVD". If not there, insert the recovery CD and run the "Extras Installer", then select AmiDVD and allow it to install.

2. With the recovery CD still in the drive, open a Shell and enter the following commands:

MakeDir RAM:BootVol
Copy CD0: RAM:BootVol ALL CLONE
Copy SYS:Kickstart/PCIGraphics.card RAM:BootVol/System/Kickstart
Copy SYS:Kickstart/RadeonHD.chip RAM:BootVol/System/Kickstart

Then make a note of the exact volume name of CD0:. Mine was "AmigaOS 4.1 Update 5" for this example.

3. Now remove the recovery CD and replace it with a blank CD-ROM.

4. Open SYS:Utilities/AmiDVD/AmiDVD

5. From the "CreateImage" Tab, Set source to RAM:BootVol, then set VolumeName to "AmigaOS 4.1 Update 5".

6. Select Bootable AmigaOS4 and finally select "Create Image".

7. Now on to tab2, "Burn Image", and click on "Burn CD-R"

That's it! The resulting disk should be identical to the original but will boot properly with newer graphics cards.

Remember
This new boot image is under the same agreement that the RadeonHD drivers were distributed under. It is NOT OK to share this disk with others.

Intermittent power on/off problems

Check all PCI(e) cards are securely in their slots.

Problems updating your Kickstart

Kickstart will load from the highest priority bootable partition on THE FIRST DRIVE ONLY. If your highest priority bootable drive is on a second SATA disk, then that will boot over the kickstart found on Disk1.

Updating Nemo's Firmware

Warning, this procedure is not harmless and should only be done when you know exactly what you are doing.
Updating Nemo firmware


AmigaOS 4.1 Final Edition FAQ

Insert documentation here...